Testing app migration platform without automated pathway

Hi,

Recently, we started implementing the app migration assistant for our apps.
We are using the following approach/dependencies:

  1. OSGI dynamic dependencies: atlassian-app-cloud-migration-osgi v0.3.6
  2. CCMA v3.1.7
  3. feature flags migration-assistant.app-migration.feature is enabled in Confluence.
  4. Confluence server v7.10.2

We have the migration path already available online but when I create a new migration plan through the assistant UI, the migration cannot start due to missing automated pathway. Since we are still in the implementation phase, is there any way to test the migration platform without enabling the automated pathway or am I missing something here?

thanks

1 Like

Hi Behrouz,

As long as you have the followings in place, app migration platform lets you migrate apps.

  1. Have a listener implemented
  2. In AppAssessment flow, select ‘NeededInCloud’ - despite you have a path or not. And complete the flow once. This flow is not meant to be blocking at present, so you should be able to complete this.
  3. Make sure that App is installed on the cloudsite you would like to migrate too.

Also note that at present only those apps that have the same key on server and cloud can be migrate, so if serverAppKey and cloudAppKey are different then you can’t migrate.

Let me know if the above worked.

Regards,
Anshuman

Hi Anshuman,
Thanks for your reply,

I had followed the steps you mentioned above,

I also implemented both listeners interfaces available in migration OSGi and none of them worked. (AppCloudMigrationListenerV1, AppCloudMigrationListener)

I attach a video showing the steps I followed to create a migration plan here:

Regards,
Behrouz

Hi @AnshumanTiwari - was there anything else we needed to implement to be able to test? Currently, this was blocking our progress.

In case it is required, these are our related Atlassian Migration tickets - https://jira.atlassian.com/browse/MIG-464 (PDF) / https://jira.atlassian.com/browse/MIG-465 (Word)

Thanks, Thomas (K15t)

Hi @behrouz and @thomasr, from EAP, the completion of App Assessment is necessary for those migrations that have Apps involved.

Therefore, you need to make sure that every installed App should have a deterministic state either - ‘Needed in cloud’ or ‘Not needed in Cloud’ or ‘Use Alternative’. In App Assessment, please make sure that it is true for every app and then go through the flow.

Hi @AnshumanTiwari

The workaround you provided was working fine but after updating CCMA to v3.1.8, and the wanted apps for migration are not listed in the migration plan and the app migration listener not being called anymore.

Do you have any ideas about that?

Regards,
Behrouz

Hi @behrouz,

Please let me jump in here for my colleague. Generally we find that sometimes on the upgrade depending on how you’ve implemented the listener that a complete restart of Confluence Server will help to reset the apps. Or at least at a minimum restart your app after making sure CCMA is enabled.

Exactly which page are you referring to when you say

the wanted apps for migration are not listed in the migration plan

just so I can be sure about your issue.

Regards,
James.

Hi @jrichards
Thanks for your reply,

I also restarted the Confluence Server but it didn’t help.
The page Choose what to migrate in the previous version was showing the apps being migrated.

I attach screenshots of those pages.

Hi @behrouz,

It looks like you need to reset the dark feature flag to turn App Migration on. There should be a large orange banner at the top to let you know you’re running the EAP code.

Please follow the instruction in this step in the Getting Started Guide

Specifically,

  1. Go to <Confluence_URL>/admin/darkfeatures.action
  2. Scroll down and enter migration-assistant.app-migration.feature
  3. Click Save

This should activate the EAP App Migration features. You do not need to restart. (A restart will clear out the dark feature.) I also recommend reviewing the Getting Started page again because there might have been some changes since the last time you viewed it.

Regards,
James.